Service degredation from Cloud provider network connectivity
Resolved·Degraded performance

The incident has been resolved, and systems are operational. The last observed instance of the issue was 11:00AM ET / 10:00AM CT / 8:00AM PT.

We have monitored the fix we deployed to mitigate the 3rd party network connectivity issue.

We also met with Cloud provider to confirm their network issue has been resolved.

We sincerely apologize for any inconvenience and thank you for your patience.

Thu, Oct 9, 2025, 07:33 PM
(2 months ago)
·
Affected components
Updates

Resolved

The incident has been resolved, and systems are operational. The last observed instance of the issue was 11:00AM ET / 10:00AM CT / 8:00AM PT.

We have monitored the fix we deployed to mitigate the 3rd party network connectivity issue.

We also met with Cloud provider to confirm their network issue has been resolved.

We sincerely apologize for any inconvenience and thank you for your patience.

Thu, Oct 9, 2025, 07:33 PM

Monitoring

A fix has been deployed to mitigate the 3rd party network connectivity issue. Our team is currently monitoring the system to ensure stability and performance. Further updates will follow.

Thu, Oct 9, 2025, 06:23 PM(1 hour earlier)

Identified

We have identified the issue impacting our systems. It is a 3rd party network connectivity issue that continues to intermittently experience issues. We are working on a fix that will minimize the impact to our customers and their callers. We appreciate your patience as we promptly restore full service.

Thu, Oct 9, 2025, 03:56 PM(2 hours earlier)

Investigating

We are currently investigating an issue impacting our systems. It appears a 3rd party network connectivity issue has been resolved, but our team continues to investigate.

Thu, Oct 9, 2025, 02:44 PM(1 hour earlier)

Investigating

We are currently investigating an issue impacting our systems. Our team is actively working to determine the cause.

Thu, Oct 9, 2025, 01:51 PM(52 minutes earlier)
Powered by